Workshop การคอนฟิก RIP เร้าท์ติ้งโปรโตคอล บนอุปกรณ์เร้าท์เตอร์โอเอส

ช่วงนี้กำลังซ้อมมือเรื่องเร้าท์ติ้ง (Routing) เลยจะเขียนเป็นบทความบ่อยหน่อยน่ะ ฮ่าๆๆๆ

วันนี้ขอว่าด้วยเรื่อง RIP Routing Protocol กันสักหน่อย

RIP หรือ ชื่อเต็ม Routing Information Protocol เป็นรูปแบบการหาเส้นทางแบบหนึ่ง Distance Vector Routing ซึ่งในการคำนวนเส้นทางนั้น RIP จะใช้วิธีคำนวน Hop Count หรือ จำนวน Hop ที่เร้าท์ติ้งจะวิ่งผ่านเส้นทางนั้น แล้วยึดเอาเส้นทางที่สั้นที่สุด คือ ดู Hop ที่สั้นที่สุด นั้นเอง

RIP นั้นเหมาะสำหรับเน็ตเวิร์คไม่ใหญ่มากนัก ซึ่งโปรโตคอลนี้จะมีการสื่อกันกันทุกๆ 30 วินาที (หรือ เราสามารถกำหนดเวลาได้เอง)

RIP นั้นมี 2 เวอร์ชั่น v1 (Class full) และ v2 (Class less) ซึ่งสำหรับ v2 นั้นมีคุณสมบัติ เรื่องรองรับการทำ การยืนยันตัวตน เพื่อความปลอดภัย Authentication ซึ่งรองรับทั้งแบบ Plain text และ MD5

RIP รับส่งได้มากสุด 15 Hop Count

ผมมีเน็ตเวิร์คไดอะแกรม ดังต่อไปนี้

รายละเอียด (Detail)

  1. มีเร้าท์เตอร์ทั้งหมด 4 ตัว Router-1 , Router-2, Router-3, Router-4
  2. เร้าท์เตอร์ทั้ง 4 ตัวนี้มีเน็ตเวิร์คภายใน (Local Area Network) และมีการกำหนดไอพีแตกต่างกันไป ดังภาพ
  3. ต้องการใช้งานเร้าท์ติ้งประเภท RIP (Routing Information Protocol) สำหรับการเลือกเส้นทาง

วัตถุประสงค์ (Objective)

  1. เครื่องลูกข่ายทุกเครื่อง PC-1 , PC-2 , PC-3, PC-4 ต้องสามารถ ping หากันเจอทั้งหมด

เริ่มคอนฟิกเร้าท์เตอร์ Router-1

# sep/03/2018 09:20:45 by RouterOS 6.42.7
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=11.11.11.2-11.11.11.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether3 name=dhcp1
/ip address
add address=12.12.12.1/24 interface=ether1 network=12.12.12.0
add address=14.14.14.1/24 interface=ether2 network=14.14.14.0
add address=11.11.11.1/24 interface=ether3 network=11.11.11.0
/ip dhcp-server network
add address=11.11.11.0/24 dns-server=8.8.8.8 gateway=11.11.11.1
/routing rip network
add network=11.11.11.0/24
add network=12.12.12.0/24
add network=14.14.14.0/24
/system identity
set name=R1

เริ่มคอนฟิกเร้าท์เตอร์ Router-2

# sep/03/2018 09:21:20 by RouterOS 6.42.7
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=22.22.22.2-22.22.22.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether3 name=dhcp1
/ip address
add address=12.12.12.2/24 interface=ether1 network=12.12.12.0
add address=23.23.23.2/24 interface=ether2 network=23.23.23.0
add address=22.22.22.1/24 interface=ether3 network=22.22.22.0
/ip dhcp-server network
add address=22.22.22.0/24 dns-server=8.8.8.8 gateway=22.22.22.1
/routing rip network
add network=22.22.22.0/24
add network=12.12.12.0/24
add network=23.23.23.0/24
/system identity
set name=R2

เริ่มคอนฟิกเร้าท์เตอร์ Router-3

# sep/03/2018 09:22:06 by RouterOS 6.42.7
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=33.33.33.2-33.33.33.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether3 name=dhcp1
/ip address
add address=23.23.23.3/24 interface=ether1 network=23.23.23.0
add address=34.34.34.3/24 interface=ether2 network=34.34.34.0
add address=33.33.33.1/24 interface=ether3 network=33.33.33.0
/ip dhcp-server network
add address=33.33.33.0/24 dns-server=8.8.8.8 gateway=33.33.33.1
/routing rip network
add network=33.33.33.0/24
add network=23.23.23.0/24
add network=34.34.34.0/24
/system identity
set name=R3

เริ่มคอนฟิกเร้าท์เตอร์ Router-4

# sep/03/2018 09:22:34 by RouterOS 6.42.7
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=44.44.44.2-44.44.44.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether3 name=dhcp1
/ip address
add address=34.34.34.4/24 interface=ether2 network=34.34.34.0
add address=14.14.14.4/24 interface=ether1 network=14.14.14.0
add address=44.44.44.1/24 interface=ether3 network=44.44.44.0
/ip dhcp-server network
add address=44.44.44.0/24 dns-server=8.8.8.8 gateway=44.44.44.1
/routing rip network
add network=44.44.44.0/24
add network=34.34.34.0/24
add network=14.14.14.0/24
/system identity
set name=R4

ตัวอย่างผลการทดสอบ ping

ทดสอบการ Trace route จากเร้าท์เตอร์ PC-1 ไปที่ PC-4

จะเห็นว่า ระบบจะทำการเลือกเส้นทางที่สั้นสุดมาให้เรา คือ ผ่านเร้าท์เตอร์น้อยสุด (Hop) มาให้เรา เพราะเส้นทาง มี 2 เส้นทาง คือ

  1. เส้นทางวิ่งจาก Router-1 ผ่าน Router-4 ไปยัง PC-4
  2. เส้นทางวิ่งจาก Router-2 ผ่าน Router-2 ผ่านไปยัง Router-3 ผ่านไปยัง Router-4 และสุดท้ายไปที่ PC-4

ดังนั้นเส้นทางที่สั้นสุด คือผ่าน hop น้อยสุด คือ เส้นทางแรก เร้าท์เตอร์จึงเลือกเส้นทางนี้ ในการเดินทางนั่นเอง

ตัวอย่างเส้นทางที่ 1

ตัวอย่างเส้นทางที่ 2

อ้างอิงข้อมูลจากเว็บ

https://wiki.mikrotik.com/wiki/Manual:Routing/RIP
http://forum.siamnetworker.com/index.php?topic=454.0

Leave a Reply

อีเมลของคุณจะไม่แสดงให้คนอื่นเห็น ช่องที่ต้องการถูกทำเครื่องหมาย *