การคอนฟิก DHCP Relay บนอุปกรณ์ RouterOS

บทความนี้ จะพูดถึงเรื่องการคอนฟิก DHCP Relay บนอุปกรณ์ RouterOS กันสักหน่อย อ้างอิง บทความ Wiki MikroTik อ่านได้จากที่นี่เลยครับ

ซึ่งต้องบอกก่อนว่า การใช้งาน DHCP Relay นั้น มักมีการใช้งานในเน็ตเวิร์คใหญ่ๆ สักนิด เพื่อลดการทำงานของอุปกรณ์ และส่วนหนึ่งคือ การแบ่งหน้าที่ของอุปกรณ์ในการทำงาน

ลองนึกภาพอย่างนี้ครับ ปกติแล้ว เราจะใช้เร้าท์เตอร์ (ไมโครติก) เป็นตัวจ่าย DHCP หรือเป็นตัวจ่ายไอพีให้กับคอมพิวเตอร์ในเครือขายของเรา ลองนึกภาพว่า แล้วถ้าเร้าท์เตอร์เราเผอิญว่า เสีย พัง กลับบ้านเก่า… ปัญหาอะไรจะเกิดขึ้น สิ่งที่จะเกิดก็คือ คอมพิวเตอร์ภายในของเรา ก็ไม่สามารถทำงานได้ เพราะไม่มีเครื่องจ่าย ไอพี (จริงๆ แล้วเราก็แค่ฟิกไอพีให้เครื่องภายในก็ใช้ได้ล่ะ) แต่ ถ้ามีแค่เครื่องสองเครื่องมันก็ทำได้แหละ แต่ถ้าเป็นร้อยๆ เครื่อง คงลำบากอ่ะนะ..

ในเน็ตเวิร์คใหญ่ๆ จึงมีการแบ่งหน้าที่การทำงานของอุปกรณ์ คือ แยกอุปกรณ์ Firewall Gateway และ DHCP Server ออกจากกัน เรียกได้ว่า เวลาพัง ก็พังไปทีละส่วนละกัน ฮ่าๆๆ

เอาล่ะ มาลงวิธีการคอนฟิกอุปกรณ์กันเลยดีกว่า ร่ายยาว เสียเวลา ไปหาอ่านทฤษฎี เพิ่มเอาเองละกัน (ดูอ้างอิงท้ายบทความ)

 

เราจะคอนฟิกตามเน็ตเวิร์คไดอะแกรม ตัวอย่างนี้กันครับ

ในไดอะแกรมนี้ ผมมีเร้าท์เตอร์ทั้งหมด 2 ตัวด้วยกัน

  1. ROS-1 ทำหน้าเป็น DHCP Server จริง ๆ แล้ว สามารถใช้ คอมพิวเตอร์ ลง Windows Server 2012 แล้วเปิด DHCP Server ไว้ก็ได้ แต่ในตัวอย่างผมใช้ RouterOS เป็นตัว DHCP Server นะครับ
  2. ROS-2 ทำหน้าที่เป็นอินเตอร์เน็ตเกตเวย์ ในองค์กรของเรา ดังนั้น Firewall Policy ต่างๆ ก็จะทำผ่านตัวที่สองนี้ครับ (ให้ตัวที่ 1 ทำหน้าที่แค่จ่ายไอพีให้เท่านั้น)

คอนฟิกเร้าท์เตอร์ ROS-1 (DHCP Server)

# sep/02/2018 09:28:31 by RouterOS 6.42.7
# software id = C74Z-3IFR
/ip pool
add name=pool-dhcp ranges=192.168.0.2-192.168.0.254
/ip dhcp-server
add address-pool=pool-dhcp disabled=no interface=ether1 name=dhcp-server \
relay=192.168.0.1
/ip address
add address=10.10.10.1/30 interface=ether1 network=10.10.10.0
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.0.1
/ip route
add distance=1 dst-address=192.168.0.0/24 gateway=10.10.10.2
/system identity
set name=R1

คอนฟิกเร้าท์เตอร์ ROS-2 (Internet Gateway)

# sep/02/2018 09:30:37 by RouterOS 6.42.7
# software id = C74Z-3IFR
/ip address
add address=10.10.10.2/30 interface=ether2 network=10.10.10.0
add address=192.168.0.1/24 interface=ether5 network=192.168.0.0
add address=10.100.100.101/24 interface=ether1 network=10.100.100.0
/ip dhcp-relay
add dhcp-server=10.10.10.1 disabled=no interface=ether5 local-address=\
192.168.0.1 name=dhcp-relay
/ip dns
set servers=8.8.8.8
/ip firewall nat
add action=masquerade chain=srcnat
/ip route
add distance=1 gateway=10.100.100.100
add disabled=yes distance=1 gateway=10.10.10.1
/system identity
set name=R2

ทดสอบใช้คอมพิวเตอร์ PC-1 ร้องขอไอพี (Request)

ทดสอบออกอินเตอร์เน็ต (ด้วยการ ping)

ทดสอบโดยการ ping www.otiknetwork.com และ ping 8.8.8.8 สามารถรับ dhcp ได้ และ สามารถออกสู่อินเตอร์เน็ตได้ปกติ

สุดท้าย
จากตัวอย่างการคอนฟิกนี้ คงเป็นประโยชน์สำหรับท่านที่สนใจ นะครับ

อ้างอิงข้อมูลจากเว็บ

เว็บอ้างอิงที่ 1 Youtube
Wiki Mikrotik
wikipedia

One comment

Leave a Reply

อีเมลของคุณจะไม่แสดงให้คนอื่นเห็น ช่องที่ต้องการถูกทำเครื่องหมาย *