Workshop การทำเร้าท์แบบ Static Route บนอุปกรณ์ RouterOS

สวัสดีครับ เช้านี้มาทำเวิร์คช๊อป เกี่ยวกับเรื่องเร้าท์ติ้งกันต่อ ซึ่งก่อนหน้าผมเขียนถึงเรื่อง Basic OSPF ไปแล้ว อ่านเรื่อง OSPF

ผมมีผังเน็ตเวิร์คดังภาพตัวอย่างนี้

อธิบายเน็ตเวิร์คไดอะแกรม ดังนี้

  1. มีเร้าท์เตอร์ทั้งหมด 3 ตัว คือ R-1 , R-2 , R-3
  2. เร้าท์เตอร์ทั้งสามตัวให้บริการ DHCP Server และมีการกำหนดไอพีเน็ตเวิร์คภายใน ตามผัง
  3. แต่ละเน็ตเวิร์คมีคอมพิวเตอร์ ชื่อ PC-1, PC-2, PC-3 และมีไอพีดังไดอะแกรม
  4. เร้าท์เตอร์แต่ละตัวมีการกำหนด Static Route เพื่อสร้างเส้นทางเชื่อมต่อเน็ตเวิร์ค

เป้าหมายของ Workshop นี้

  1. คอมพิวเตอร์ PC-1, PC-2 , PC-3 ต้องสามารถ ping หากันได้ทั้งหมด

เริ่มการคอนฟิกเร้าท์เตอร์แต่ละตัวกันเลย

การคอนฟิกเร้าท์เตอร์ตัว R-1

# sep/02/2018 02:49:02 by RouterOS 6.42.7
/ip pool
add name=dhcp_pool0 ranges=11.11.11.2-11.11.11.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether5 name=dhcp1
/ip address
add address=12.12.12.1/24 interface=ether1 network=12.12.12.0
add address=11.11.11.1/24 interface=ether5 network=11.11.11.0
/ip dhcp-server network
add address=11.11.11.0/24 dns-server=8.8.8.8 gateway=11.11.11.1
/ip firewall nat
add action=masquerade chain=srcnat
/ip route
add distance=1 dst-address=22.22.22.0/24 gateway=12.12.12.2
add distance=1 dst-address=23.23.23.0/24 gateway=12.12.12.2
add distance=1 dst-address=33.33.33.0/24 gateway=12.12.12.2
/system identity
set name=R1

การคอนฟิกเร้าท์เตอร์ตัว R-2

# sep/02/2018 02:50:00 by RouterOS 6.42.7
/ip pool
add name=dhcp_pool0 ranges=22.22.22.2-22.22.22.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether5 name=dhcp1
/ip address
add address=12.12.12.2/24 interface=ether1 network=12.12.12.0
add address=23.23.23.2/24 interface=ether2 network=23.23.23.0
add address=22.22.22.1/24 interface=ether5 network=22.22.22.0
/ip dhcp-server network
add address=22.22.22.0/24 dns-server=8.8.8.8 gateway=22.22.22.1
/ip firewall nat
add action=masquerade chain=srcnat
/ip route
add distance=1 dst-address=11.11.11.0/24 gateway=12.12.12.1
add distance=1 dst-address=33.33.33.0/24 gateway=23.23.23.3
/system identity
set name=R2

การคอนฟิกเร้าท์เตอร์ตัว R-3

# sep/02/2018 02:50:27 by RouterOS 6.42.7
/ip pool
add name=dhcp_pool0 ranges=33.33.33.2-33.33.33.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether5 name=dhcp1
/ip address
add address=23.23.23.3/24 interface=ether1 network=23.23.23.0
add address=33.33.33.1/24 interface=ether5 network=33.33.33.0
/ip dhcp-server network
add address=33.33.33.0/24 dns-server=8.8.8.8 gateway=33.33.33.1
/ip firewall nat
add action=masquerade chain=srcnat
/ip route
add distance=1 dst-address=11.11.11.0/24 gateway=23.23.23.2
add distance=1 dst-address=12.12.12.0/24 gateway=23.23.23.2
add distance=1 dst-address=22.22.22.0/24 gateway=23.23.23.2
/system identity
set name=R3

ตัวอย่างการทดสอบ ping

ทดสอบ ping จากเครื่อง PC-1 ไปยัง PC-2 และ PC-3

ทดสอบ ping จากเครื่อง PC-2 ไปยัง PC-1 และ PC-3

ทดสอบ ping จากเครื่อง PC-3 ไปยัง PC-1 และ PC-2

ผมอัดเพิ่มเติมเป็นวีดีโอไว้ (มีผิดพลาดเรื่องไอพีเล็กน้อย ลองดูนะครับ)

Leave a Reply

อีเมลของคุณจะไม่แสดงให้คนอื่นเห็น ช่องที่ต้องการถูกทำเครื่องหมาย *