การคอนฟิกไดนามิกเร้าท์ติ้ง OSPF ขั้นพื้นฐาน (สำหรับผู้เริ่มต้นเด้า DAo)

สวัสดีครับ วันนี้วันหยุด ระหว่างที่นั่งดูกีฬาเอเชียนเกมส์ 2018 ก็นั่งทำ Lab ทบกวนไปเรื่อยๆ เลยถือโอกาสนี้เขียนเป็นบทความง่ายๆ สำหรับท่านที่ยังไม่เคยใช้งานเร้าท์ติ้งแบบไดนามิก ที่ชื่อว่า OSPF กันสักหน่อย

หลายๆ คนอาจจะมีคำถาม OSPF คืออะไร ??

อธิบายสั้นๆ OSPF มันคือ ระบวนการหาเส้นทางแบบอันโนมัติ ซึ่งเป็นโปรโคคอลมาตรฐาน ที่อุปกรณ์เร้าท์ทิ้งทุกๆ แบรน มีให้ใช้งาน ทั้ง Cisco หรือแม้กระทั่ง MikroTik เองก็มีให้ใช้งาน

OSPF ย่อมาจากภาษาอังกฤษ จากคำว่า Open Short Path First มันคือ หาเส้นทางที่สั้นที่สุด จากเส้นทางเลือกที่มีให้ โดยดูจากค่าคอท์ส (Cost) ที่มีนั่นเอง รายละเอียด ลองไปหาอ่านเพิ่มเติมนะครับ ไม่ยาก เพราะมัน

หัวใจหลักๆ ของการสั่งให้ OSPF ทำงาน คือ เราต้องกำหนด 2 ส่วนหลักๆ นี้เพื่อให้ OSPF ทำงาน

  1. กำหนดเน็ตเวิร์ค อย่างน้อย 1 เน็ตเวิร์ค
  2. กำหนดแอร์เรีย (Area) ปกติจะมี Area 0 (Backbone) อยู่แล้ว 1 Area

เมื่อเรากำหนดรายละเอียด 2 ประการด้านบนนี้แล้ว ระบบเร้าท์ติ้งจึงจะทำงาน รายมายาว มาดูตัวอย่างการทำ Lab กันเลยดีดว่า

ผมสร้าง Lab ขึ้นมา โดยมีเร้าท์เตอร์ทั้งหมด 3 ตัว R-1 , R-2 ,R-3 ซึ่งเร้าท์เตอร์ทั้งสามตัวนี้ จะกำหนดให้อยู่ในแอร์เรีย (Area) เดียวกัน หรือ Backbone นั่นเอง

วัตถุประสงค์ของ Lab นี้คือต้องการให้คอมพิวเตอร์ทั้งสามเครื่อง PC-1, PC-2,PC-3 ต้องสามารถสื่อสารกันได้ทั้งหมด โดยใช้ OSPF เป็นตัวเลือกเส้นทางในการทำเร้าท์ติ้งนั้นเอง มาเริ่มกันเลย

เริ่มการคอนฟิกที่ R-1 

# sep/01/2018 06:18:50 by RouterOS 6.42.7
/interface bridge
add name=Loopback
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=11.11.11.2-11.11.11.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether5 name=dhcp1
/ip address
add address=12.12.12.1/24 interface=ether1 network=12.12.12.0
add address=1.1.1.1 interface=Loopback network=1.1.1.1
add address=11.11.11.1/24 interface=ether5 network=11.11.11.0
/ip dhcp-server network
add address=11.11.11.0/24 dns-server=8.8.8.8 gateway=11.11.11.1
/ip firewall nat
add action=masquerade chain=srcnat
/routing ospf network
add area=backbone network=1.1.1.1/32
add area=backbone network=12.12.12.0/24
add area=backbone network=11.11.11.0/24
/system identity
set name=R1

เริ่มการคอนฟิกที่ R-2

# sep/01/2018 06:25:58 by RouterOS 6.42.7
/interface bridge
add name=Loopback
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=22.22.22.2-22.22.22.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether5 name=dhcp1
/ip address
add address=12.12.12.2/24 interface=ether1 network=12.12.12.0
add address=2.2.2.2 interface=Loopback network=2.2.2.2
add address=23.23.23.2/24 interface=ether2 network=23.23.23.0
add address=22.22.22.1/24 interface=ether5 network=22.22.22.0
/ip dhcp-server network
add address=22.22.22.0/24 dns-server=8.8.8.8 gateway=22.22.22.1
/ip firewall nat
add action=masquerade chain=srcnat
/routing ospf network
add area=backbone network=2.2.2.2/32
add area=backbone network=12.12.12.0/24
add area=backbone network=23.23.23.0/24
add area=backbone network=22.22.22.0/24
/system identity
set name=R2

เริ่มการคอนฟิกที่ R-3

#sep/01/2018 06:36:24 by RouterOS 6.42.7
/interface bridge
add name=Loopback
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=33.33.33.2-33.33.33.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether5 name=dhcp1
/ip address
add address=3.3.3.3 interface=Loopback network=3.3.3.3
add address=33.33.33.1/24 interface=ether5 network=33.33.33.0
add address=23.23.23.3/24 interface=ether1 network=23.23.23.0
/ip dhcp-server network
add address=33.33.33.0/24 dns-server=8.8.8.8 gateway=33.33.33.1
/routing ospf network
add area=backbone network=3.3.3.3/32
add area=backbone network=23.23.23.0/24
add area=backbone network=33.33.33.0/24
/system identity
set name=R3

ทดสอบผล โดยการ ping จาก PC-1 ไปยัง PC-2 และ PC-3

ทดสอบผล โดยการ ping จาก PC-2 ไปยัง PC-1 และ PC-3

ทดสอบผล โดยการ ping จาก PC-3 ไปยัง PC-1 และ PC-2

จากการทดสอบ คอมพิวเตอร์ทุกจุด สามารถสื่อสารกันได้ทั้งหมด

ต่อมาเรามาดูที่ตารางเร้าท์ ของเร้าท์เตอร์แต่ละตัวกันครับ ว่าตารางเร้าท์นั้นมีเส้นทางอะไรบ้าง

จะเห็นว่าในตารางเร้าท์เรา มีเร้าท์ประเภท DAo แสดงขึ้นมา แล้วอะไรคือ DAo กันละ

DAo เป็นตัวย่อ มาจาก D = Dynamic (คือระบบสร้างเองอัตโนมัติ) , A = Active (สถานะทำงานอยู่) , o = OSPF (คือเร้าท์ติ้งประเภท OSPF) นั่นเอง

เร้าท์เตอร์ R-1

เร้าท์เตอร์ R-2

เร้าท์เตอร์ R-3

Leave a Reply

อีเมลของคุณจะไม่แสดงให้คนอื่นเห็น ช่องที่ต้องการถูกทำเครื่องหมาย *