ปัญหาอินเตอร์เฟสไม่ตรงใน GNS3 เมื่อใช้งานกับ RouterOS

สวัสดีครับ เช้านี้ขอมาเขียนบทความ อย่างน้อยเอาไว้เตือนความจำตัวเองสักนิด สำหรับปัญหา เล็กๆ ที่เจอใน GNS3

เรื่องมีอยู่ว่า ผมได้เข้าเรียนคอร์ส MTCINE ซึ่งเป็นคอร์สที่สอนเกี่ยวกับเร้าท์ติ้ง ขั้นสูง ของไมโครติก ตัวหนึ่งที่เป็น มาตรฐาน  เนื่องจากเป็นมาตรฐาน จึงสามารถเอาคอนเซ็ปนี้ไปใช้กับเร้าท์เตอร์ยี่ห้ออื่นๆ ได้ด้วย เช่นกัน ไม่ว่าจะ Cisco หรืออื่นๆ ที่รองรับ BGP เร้าท์ติ้ง

แต่ด้วยเนื้อหานี้ต้องใช้เร้าท์เตอร์มากกว่าหนึ่งตัว ในการทำ Lab ซึ่งในคอร์สนี้เราได้เลือกใช้ GNS3 เป็นเครื่องมือในการทดสอบทำเร้าท์ติ้ง ปัญหา มีอยู่ว่า พอเราทำผังเน็ตเวิร์คเรียบร้อยแล้ว เราก็ต้องคอนฟิกตามผังที่เราได้ออกแบบไว้

ดูตัวอย่างภาพ

ตัวอย่างการ เชื่อมต่ออินเตอร์เฟส

จากรูป เราทำการเชื่อมต่อ R-1 ไปที่ R-2 ด้วยอินเตอร์เฟส หมายเลข ether1 เมื่อเราทำการคอนฟิกค่า ได้ดังภาพ คือเชื่อม ether1 กับ ether1

ลองทำการทดสอบด้วยการ ping ระหว่างสองเร้าท์เตอร์ปรากฎว่า ไม่สามารถสื่อสารกันได้ นั่นเพราะปัญหาเจ้า GNS3 มันแสดงค่าอินเตอร์เฟส หรือ พอร์ต ไม่ตรง ลองใช้คำสั่ง /ip nei print ดูจะพบว่า รูปภาพ กับค่าคอนฟิกจริงๆ มันไม่ตรงกันเอาเสียเลย

มาดูวิธีแก้ไขกัน ให้เปิด GNS3 ขึ้นมาแล้วกำหนดค่าดังต่อไปนี้

Edit > Perferences > QEMU > Qemu VMs > จากนั้นเลือกเร้าท์เตอร์โอเอส ที่เราต้องการแก้ไข > Edit

จากนั้นให้เลือกที่แท๊ป Network ตรงส่วนของ type ให้เลือกเป้น Legacy paravirtualed Network … แล้วทำเครื่องหมายถูกที่หน้า Use the legacy networking mode จากนั้นคลิกที่ OK แล้วก็ OK

หลังจากนั้นให้คุณลองเพิ่มเร้าท์เตอร์ใหม่ (ไฟล์เดิมที่บันทึกไว้ใช้ไม่ได้นะครับ) แล้วลองกำหนดค่าใหม่ จากนั้นลองตรวจสอบอีกครั้ง ภาพและค่าคอนฟิกจะตรงกันแล้ว จะได้ไม่งง พร้อมทำ lab ต่อได้แล้วครับ

ตัวอย่างค่าคอนฟิก R-1

/ip address
add address=192.168.1.1/30 interface=ether1 network=192.168.1.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/system identity
set name=R1

ตัวอย่างค่าคอนฟิก R-2

/ip address
add address=192.168.1.2/30 interface=ether1 network=192.168.1.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/system identity
set name=R2

เพิ่มเติมวีดีโอให้ เพื่อความเข้าใจมากขึ้น

ขอให้ทุกคนโชคดี ฮ่าๆๆ รวมถึงผมด้วย วันนี้ต้องไปเรียนต่อล่ะ

อำนวย ปิ่นทอง
โอติก เน็ตเวิร์ค จำกัด

2 comments

  1. สวัสดีครับอาจารย์ คือตอนนี้ผมมีปัญหาคือ mikrotik ที่ต่อกับ host มีอาการเหมือนส่งข้อมูลช้า
    เช่น ผมใช้ winbox เชื่อมต่อเข้าไปจะมีอาการหน่วงครับ ประมาณว่า กดดู ip address ต้องรอแป๊ปนึงกว่ามันจะโผล่มา เมื่อทดสอบ ping เข้าไปดู ปรากฎว่าค่าปิงสูงมากครับ 300ms-1000ms สลับกันเลยครับ ไม่ทราบว่าอาจารย์เคยเจอปัญหาเหล่านี้ไหมครับ

Leave a Reply

อีเมลของคุณจะไม่แสดงให้คนอื่นเห็น ช่องที่ต้องการถูกทำเครื่องหมาย *